Postgres.app

Der schnellste Weg zu PostgreSQL am Mac

Postgres.app 2.0.2

Dies ist die aktuelle Version von Postgres.app. Sie benötigt macOS 10.10 oder neuer.

Folgende Server-Versionen sind im Paket inkludiert:

  • PostgreSQL 9.6.2 (mit PostGIS 2.3.2)

  • PostgreSQL 9.5.6 (mit PostGIS 2.2.5)

Versionshinweise für Postgres.app 2.0.2

Postgres.app 2.0.2 herunterladen

Weitere Versionen

Wir unterstützen auch einige ältere Versionen von PostgreSQL. Diese Versionen laufen auf macOS 10.7 oder neuer. Sie haben noch die alte Benutzeroberfläche, und enthalten jeweils nur eine einzelne Version von PostgreSQL.

Baukastensystem

Die aktuelle Version von Postgres.app unterstützt verschiedene Versionen von PostgreSQL. Standardmäßig sind 9.5 und 9.6 inkludiert, du kannst aber auch weitere PostgreSQL-Versionen hinzugügen.

Um die Binaries für die verschiedenen Server-Versionen in Postgres.app anzuzeigen, klicke mit der rechten Maustaste auf Postgres.app und wähle “Paketinhalt zeigen”. Du findest die Binaries dann im Unterordner Contents/Versions.

Wenn du also zb. PostgreSQL 9.4 mit dem neuen UI verwenden willst, kopiere den 9.4 Ordner aus einer alten Version in die neue Version.

Wenn du nun Postgres.app neu startest, kannst du einen neuen Server mit PostgreSQL 9.4 erstellen.

Durch die zusätzlichen Dateien im Paket kann die Codesignatur eventuell nicht mehr überprüft werden. Falls beim Öffnen der App eine Fehlermeldung auftritt, musst du sie über das Kontext-Menü öffnen.

Noch eine kurze Warnung: Die automatische Update-Funktion löscht zusätzliche PostgreSQL-Versionen. Du musst nach einem Update wieder die alten Binaries kopieren.