Postgres.app

The easiest way to get started with PostgreSQL on the Mac

Legacy Downloads for older Macs

We no longer update our legacy releases.

We provide these downloads for people who are still on older versions of macOS, but we no longer update them.

If you are running macOS 10.10 or later, you can use Postgres.app v2.1.x with the modern UI.

If you have an even older Mac, you can use the Legacy version of Postgres.app (supports only a single version of PostgreSQL).

Postgres.app with PostgreSQL 9.5, 9.6 and 10

  • Postgres.app v2.1.9
  • Requires macOS 10.10
  • Download Size 156MB
  • PostgreSQL 10.10 / PostGIS 2.4.7 / plv8 1.4.8
  • PostgreSQL 9.6.15 / PostGIS 2.3.9 / plv8 1.4.8
  • PostgreSQL 9.5.19 / PostGIS 2.2.8 / plv8 1.4.8
⤓ Download

Legacy Postgres.app with PostgreSQL 10

  • Requires macOS 10.7
  • Download Size 65MB
  • PostgreSQL 10.10 / PostGIS 2.4.7 / plv8 1.4.8
⤓ Download

Legacy Postgres.app with PostgreSQL 9.6

  • Requires macOS 10.7
  • Download Size 49MB
  • PostgreSQL 9.6.15 / PostGIS 2.3.9 / plv8 1.4.8
⤓ Download

Legacy Postgres.app with PostgreSQL 9.5

  • Requires macOS 10.7
  • Download Size 44MB
  • PostgreSQL 9.5.19 / PostGIS 2.2.8 / plv8 1.4.8
⤓ Download

Legacy Postgres.app with PostgreSQL 9.4

  • Requires macOS 10.7
  • Download Size 41MB
  • PostgreSQL 9.4.24 / PostGIS 2.1.9 / plv8 1.4.8
⤓ Download

Legacy Postgres.app with PostgreSQL 9.3

  • Requires macOS 10.7
  • Download Size 41MB
  • PostgreSQL 9.3.23 / PostGIS 2.1.9 / plv8 1.4.8
⤓ Download

You can find even more releases on our Releases Page on Github.